Skip to content

Plugin not working after upgrading to Wordpress 4.9.1 #51

Description

@jeremys6

It used to work perfectly,
It suddenly stoped after upgrading to Wordpress 4.9.1
The error i get is
{"code":"rest_cannot_create","message":"Sorry, you are not allowed to create posts as this user.","data":{"status":401}}

Activity

  1. terriann commented on Jan 9, 2018

    @terriann

    I was also able to reproduce this issue - it seems to be caused by characters in the user's password. Didn't get a chance to dig deeper; just noticed inconsistencies between some accounts working and some failing followed by examining and testing the differences between the accounts.

    Passwords that did not work:

    • &poV9xtbvqzI@Z7fgxZWVfmg
    • poV9xtbvqzI+Z7fgxZWVfmg

    Passwords that did work:

    • poV9xtbvqzIZ7fgxZWVfmg
    • MSv382WarLWmSoqnh1vCma

    Work Around: Remove non-alphanumeric characters from password.

  2. hypgfrch commented on Jan 12, 2019

    @hypgfrch

    Under WordPress 4.9.9 as of today, Installed manually by placing the files at 'plugins' WP folder, successfully activated by pressing "activate", and successfully tested by authenticating through 'curl'.

    My password contains non-alphanumerics.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Labels

    No labels
    No labels

    Type

    No type

    Projects

    No projects

      Milestone

      No milestone

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions